UACALI FLASH!

Requires: Internet Explorer version 5 or greater and the INTERNATIONAL Java Runtime Environment 1.3 Plug-in or greater from Sun

For more information, click here

Recommended: A fast Internet connection so you can download audio quickly

FLASH! Is our context-based flashcard exercise that lets you use various clues to think of the meaning of each flashcard in a 'deck'. FLASH! lets you listen to audio if the author of the lesson has recorded it.

CONTINUE